RÉSOLU Problème énervant de Widge

Discussion dans '[Mi Mix 2 Globale]Questions, problèmes et solutions' créé par vil_coyotte, 2 Mai 2018.


  1. Il semble que vous ne soyez pas membre de ce forum ou un membre récent.
    Sachez que seuls les membres enregistrés et ayant un minimum de 3 messages peuvent télécharger les ressources additionnelles tels les thèmes ou les mods.
    Enregistrez-vous dès à présent!
  2. Merci d'utiliser la fonction "RECHERCHE" en haut à droite de la page d'accueil. Quelqu'un a peut être eu la même question que vous et vous aurez une solution plus rapidement ainsi :-)
  3. Les nouveaux membres ou ceux disposant de moins de 3 messages sont particulièrement incités à lire la charte du forum qui contient les quelques règles applicables sur ce forum.
    Son non-respect peut entraîner des sanctions pouvant aller jusqu'au bannissement total dans le cas de récidive.
    Merci de noter que ne sont bienvenues ici que les personnes susceptibles de contribuer ici au bien-être et la convivialité au sein de la communauté. Toute personne utilisant ce site et ce forum uniquement pour nuire aux autres est priée de passer son chemin.
  1. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    #1 vil_coyotte, 2 Mai 2018
    Dernière édition: 4 Mai 2018
    Bonjour à tous.

    Sur les conseils de Mr Mangue (que je remercie encore au passage d'avoir tenté de m'aider), je poste mon souci ici.

    Voilà, j'ai un Mi Mix2, ROM officielle MIUI Global 9.5 | Stable 9.5.6.0(ODEMIFA).
    version Android 8.0.0 OPR1.170623.027
    Correctif de sécurité 2018-03-01
    Version noyau 4.4.78-perf-g3a3cdc0
    Le tel est non rooté (je suis dans les fameuses 72h).
    Bon, maintenant que vous connaissez tout de ses entrailles, voici le souci:

    Quand je veux mettre un Widget autre que celui par défaut (quand il faut qu'il soit créé par une appli), rien ne s'affiche. J'ai remarqué ça d'abord avec les Beautiful Widget qui ne voulaient pas créer le fameux Widget.
    Un remboursement plus tard, je me suis aperçu que le problème est le même avec les Widget de Yahoo Météo.

    Si je choisis un Widget déjà configuré (4*2), le widget se crée, se met à jour, pas de soucis.
    Si je choisis un widget qu'il faut configurer (4*2 aussi), mais dans lequel je demande par exemple l'affichage des températures min et max, je clique sur créer le widget, rien ne se passe.
    Le tel fait "comme si" il créait le widget mais rien n'apparaît.
    Aucun message d'erreur, aucun symptôme. Il m'ignore juste.

    Quelqu'un peut-il essayer (Yahoo Météo et ses widgets sont gratuits en plus d'être superbes) et me dire s'il y arrive ?
    Le Widget qui fonctionne est le troisième en 4*2. Les deux premiers ne fonctionnent pas.
    Je n'arrive pas à trouver ni à expliquer (et c'est ce qui m'énerve) pourquoi ça veut pas.
    J'ai trituré toutes les options possibles, validé le démarrage automatique de l'appli météo, etc... vidé le cache de données de l'appli, essayé de créer le widget et de redémarré.

    Y'a juste les rituels vaudou que j'ai pas encore fait (j'hésite, ça paraît un poil trop violent quand même juste pour avoir la météo :p ).

    Merci d'avance
     
    rodeomb aime ça.
  2. rodeomb

    rodeomb Au delà du réel

    4 Mai 2013
    766
    238
    43
    Homme
    92
    Hello
    Je viens de tester ton app météo et ses widgets... Bein aucun souci sur mon Minote 2 !!!

    Testé sur une page vierge ou presque... Donc avec assez de place pour le format par défaut.

    Je te mets screen des autorisations
    This content is protected
    This content is protected
    This content is protected
    This content is protected
    This content is protected
    This content is protected


    Envoyé de mon Mi Note 2 en utilisant Tapatalk
     
    LeGaulois aime ça.
  3. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Merci de tes tests.
    Ci joint des captures de l aconfig de l'appli chez moi :
    This content is protected


    Envoyé de mon Mi MIX 2 en utilisant Tapatalk
     
  4. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Et ça aussi
    This content is protected


    Envoyé de mon Mi MIX 2 en utilisant Tapatalk
     
  5. rodeomb

    rodeomb Au delà du réel

    4 Mai 2013
    766
    238
    43
    Homme
    92
    Ok ok [emoji108]
    Juste au cas où... Pour créer tes widgets, tu pinces l'écran avec 2 doigts puis widgets etc... Puis déplacer-déposer sur une page vierge...

    Sinon après je vois vraiment pas...

    Envoyé de mon Mi Note 2 en utilisant Tapatalk
     
  6. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Presque: au lieu de pincer, j'appuie longtemps sur une zone vide de l'écran et le menu apparaît aussi (vieux réflexe acquis avec le Nexus 6P).
    Si je suis sur la page 3, par exemple, sur laquelle il y a la place pour créer un widget, non seulement rien ne se Fait (mais ça vous le savez), mais en plus, il revient sur la page par défaut...
    Vais devenir chèvre

    Envoyé de mon Mi MIX 2 en utilisant Tapatalk
     
  7. rodeomb

    rodeomb Au delà du réel

    4 Mai 2013
    766
    238
    43
    Homme
    92
    Autre petite vérification de ce côté là...
    This content is protected


    Envoyé de mon Mi Note 2 en utilisant Tapatalk
     
  8. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Bah oui pareil, sauf que j'ai pas le coffre d'applis.
    This content is protected


    Envoyé de mon Mi MIX 2 en utilisant Tapatalk
     
  9. rodeomb

    rodeomb Au delà du réel

    4 Mai 2013
    766
    238
    43
    Homme
    92
    Il te manque surtout Disposition de l'écran d'accueil 4x6 etc...

    Plus qu'à tester la Rom bêta Global... Pas vérifié mais elle doit être dispo.

    Envoyé de mon Mi Note 2 en utilisant Tapatalk

    Édit : en plus de mémoire pour déverrouiller le BL faut être sur une bêta... Quelqu'un pour confirmer ???
     
  10. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Ben j'ai demandé le déverrouillage à Xiaomi, ça a été accepté.
    J'ai utilisé l'utilitaire fourni par Xiaomi, ça a fonctionné jusqu'à ce qu'il me dise d'attendre 71 h.
    Donc, à partir de demain après-midi.
    Je ferai un retour.
    Merci encore.
     
  11. vil_coyotte

    vil_coyotte Membre

    8 Janvier 2018
    19
    4
    3
    Homme
    Ingénieur
    LABARTHE SUR LEZE
    Bonjour,

    je viens faire un retour sur ce qui restera pour moi un mystère.

    J'ai déverrouillé le bootloader, flashé la ROM MIUI 9 version DEV 8.4.19, et rooté le téléphone. (merci à Angyann pour le tuto).
    J'ai tenté après avoir tout réinstallé et reconfiguré de refaire la manip avec le widget météo de Yahoo. ça a fonctionné du premier coup.
    Du coup, j'ai acheté à nouveau Beautiful Widget, j'ai essayé de le configurer et là aussi, ça a fonctionné du premier coup.

    Après un redémarrage, les midgets (2 en tout) ne se sont pas reconstruits. Je les ai donc refaits, modifié les options des applis concernées (démarrage auto + batterie + autorisations sur les écrans). Les widgets reconfigurés, ça a fonctionné, y compris après un arrêt marche.

    Je ne m'explique pas le souci que j'ai eu.
    Comme au déverrouillage du bootloader le tel fait une remise à zéro, je ne sais pas si c'est le reset ou les changemens de rom etc qui ont résolu le souci.

    Deux points complémentaires ceci dit:
    1. Après l'installation de TWRP, je n'arrivais pas à aller cehrcher le Magisk 16.0 que j'avais placé sur la carte SD (répertoire DATA qui ne voulait pas se monter d'après le LOG TWRP).
    J'ai donc copié le fichier sur une clé USB que j'ai branché au Mi Mix2 avec un adaptateur USB-C USB et ça a fonctionné direct.

    2. Après avoir installé la ROM DEV, le téléphone s'est bloqué. Un message disant que le téléphone était déjà associé à un compte Mi. Il me demandait le mot de passe. Quand je le rentrait, il ne pouvait pas se connecter (les SIM n'étaient pas activées) et ne pouvait pas le vérifier.
    je cliquais sur l'option présente pour configurer le WIFI, mais quand je me plaçais dans le champs "mot de passe", le clavier de saisie n'apparaissait pas (alors qu'il apparaissait bien à l'étape précédente). Impossible donc de rentrer le MDP.
    bref, bloqué et on tourne en rond.
    Pour régler mon soucis:
    j'ai un répéteur WIFI auquel j'ai viré le mot de passe de connexion. Je me suis connecté au WIFI sans mot de passe (celui du répéteur). Puis je suis revenu à l'écran qui me demandait le mot de passe du compte Xiaomi, entré le mot de passe et là, c'était OK.
    Je suis retourné sur le répéteur pour remettre le MDP (pour pas me faire pirater mon réseau perso).

    Bref, pas si simple et il faut savoir bidouiller un peu au risque de transformer son tel en presse papier si on a pas des moyens de se débrouiller en cas d'obstacle.

    Vil_coyotte
     
    rodeomb aime ça.
  12. rodeomb

    rodeomb Au delà du réel

    4 Mai 2013
    766
    238
    43
    Homme
    92
    Hello

    Bien content pour toi que cela se finisse bien malgré tes péripéties...

    Pour les widgets pas de doute pour moi ta rom d'origine était en cause...

    Quant à ton problème de MDP c'est un classique, on se fait avoir une fois... Plus jamais une 2ème fois

    Un Xiaomi ça se mérite...[emoji23] Tu as passés les épreuves [emoji106]

    Envoyé de mon Mi Note 2 en utilisant Tapatalk
     
    LeGaulois aime ça.

Partager cette page

Utilisateurs lisant le sujet (Utilisateurs: 0, Invités: 0)