QUESTION Désactivation LED lors de la charge

Discussion dans 'Mods, Magisk et Xposed' créé par kayoo, 19 Février 2016.


  1. Il semble que vous ne soyez pas membre de ce forum ou un membre récent.
    Sachez que seuls les membres enregistrés et ayant un minimum de 3 messages peuvent télécharger les ressources additionnelles tels les thèmes ou les mods.
    Enregistrez-vous dès à présent!
  2. Merci d'utiliser la fonction "RECHERCHE" en haut à droite de la page d'accueil. Quelqu'un a peut être eu la même question que vous et vous aurez une solution plus rapidement ainsi :-)
  3. Les nouveaux membres ou ceux disposant de moins de 3 messages sont particulièrement incités à lire la charte du forum qui contient les quelques règles applicables sur ce forum.
    Son non-respect peut entraîner des sanctions pouvant aller jusqu'au bannissement total dans le cas de récidive.
    Merci de noter que ne sont bienvenues ici que les personnes susceptibles de contribuer ici au bien-être et la convivialité au sein de la communauté. Toute personne utilisant ce site et ce forum uniquement pour nuire aux autres est priée de passer son chemin.
  1. kayoo

    kayoo Membre actif

    22 Janvier 2013
    30
    4
    8
    Homme
    Bonjour a tous,

    J'ai besoin d'un peu de vos lumière concernant un aspect un peu gênant.
    Toutes les nuits avant de m'endormir, je branche mon téléphone et la LED émet une intense lumière très gênante dans le noir...
    Étant un utilisateur avancé je me demande si il n'existerai une option pour désactiver cela !

    J'ai essayé de modifier mon "build.prop" comme suis :
    Code:
    ## Sauvegarde
    adb pull /system/build.prop
    
    ## Edition
    adb shell
    su -
    mount -o remount,rw /system
    cp /system/build.prop /system/build.prop.orig
    echo "" >> /system/build.prop
    echo "# CUSTOM: Desactivation LED durant la charge" >> /system/build.prop
    echo "persist.sys.charge_led=off" >> /system/build.prop
    reboot
    
    
    Au reboot, la valeur semble bien être prise en compte par le systeme :
    Code:
    adb shell getprop persist.sys.charge_led
    off
    
    Mais la LED est toujours active dès que c'est branché !

    Quelqu'un aurait une idée ? un piste ?
    Par avance, merci...
     
  2. sebastieng

    sebastieng From Rebloch-Land

    16 Juillet 2014
    298
    161
    43
    Homme
    Annecy
    Je met mon tel face vers le sol quand je charge la nuit et ça marche super :biggrin: ;)
     
    Phoenix aime ça.
  3. kayoo

    kayoo Membre actif

    22 Janvier 2013
    30
    4
    8
    Homme
    Mouais, j'avoue que je m'attendais a un autre genre de réponse :p
    Pour être honnête, je l'utilise également branché le soir dans mon lit. C'est a dire, luminosité au minimum et un mode "lecture-nuit" activé !
    Bref, tout ce qu'il faut avant de s'endormir... Sauf cette LED qui a une intensité bien trop haute et qui me dérange ainsi que Madame qui essaye de dormir...
     
  4. sebastieng

    sebastieng From Rebloch-Land

    16 Juillet 2014
    298
    161
    43
    Homme
    Annecy
    Dans une chaussette sinon ! :roflmao:
    Ok j'arrête...
    Plus sérieusement, tu pourrais te trouver un flip cover avec rabat ptêtre.
     
  5. kayoo

    kayoo Membre actif

    22 Janvier 2013
    30
    4
    8
    Homme
    J'utilise la technique du scotch noir :)

    Sinon, j'ai un début de piste :
    This content is protected


    Elle me permet en activant le droit root de désactiver ma LED uniquement en CHARGE via le mode "direct".
    Je branche mon chargeur .. ca charge sans allumer ma LED !!! Yeahhhh !
    Le soucis, c'est que ca saute des que je recois une notification :(
    Je me dois de désactiver et réactiver le mode root...

    Ya d'autre reglage dans l'appli, je doit m'y interesser pour voir (des modes Samsung et HTC...)

    Si d'autre, veulent tenter l'expérience avec moi :)
    Partagez vos réglages !
     

Partager cette page

Utilisateurs lisant le sujet (Utilisateurs: 0, Invités: 0)